Closure of octo.sh is scheduled for May 1st 2019. Please migrate as soon as possible. Repositories backups will be available upon request, after the server is offline. Contact: gitlab@octo.im

...
 
Commits (2)
......@@ -12,7 +12,7 @@
- copr
when:
- ansible_distribution == "Fedora"
- ansible_distribution_major_version > 26
- ansible_distribution_major_version is version('26', '>')
become: true
- name: Install Adapta-GTK-Theme Common Package
......
......@@ -8,5 +8,5 @@
enabled: yes
when:
- ansible_distribution == "Fedora"
- ansible_distribution_major_version > 21
- ansible_distribution_major_version is version('21', '>')
become: true
......@@ -3,11 +3,8 @@
- name: Install default packages
dnf:
name: "{{ item }}"
name: "{{ packages | union(extended_packages | default([])) | map(attribute='dnf') | list }}"
state: present
with_items:
- "{{ packages | map(attribute='dnf') | list }}"
- "{{ extend_packages | map(attribute='dnf') | list }}"
tags:
- dnf
- download
......
......@@ -3,8 +3,6 @@
- name: Install default packages
dnf:
name: "{{ item }}"
name: "{{ packages | map(attribute='apt') | list }}"
state: present
with_items:
- "{{ packages | map(attribute='apt') | list }}"
become: true
......@@ -13,7 +13,7 @@
- copr
when:
- ansible_distribution == "Fedora"
- ansible_distribution_major_version > 26
- ansible_distribution_major_version is version('26', '>')
become: true
- name: Install discord
......
......@@ -17,6 +17,6 @@
tags:
- flatpak
when:
- ansible_version.major >= 2
- ansible_version.minor >= 6
- ansible_version.major is version('2', '>=')
- ansible_version.minor is version('6', '>=')
become: true
......@@ -3,10 +3,8 @@
- name: Install gnome enhancements
dnf:
name: "{{ item }}"
name: "{{ packages | map(attribute='dnf') | list }}"
state: present
with_items:
- "{{ packages | map(attribute='dnf') | list }}"
tags:
- dnf
- download
......
......@@ -3,8 +3,6 @@
- name: Install gnome enhancements
dnf:
name: "{{ item }}"
name: "{{ packages | map(attribute='apt') | list }}"
state: present
with_items:
- "{{ packages | map(attribute='apt') | list }}"
become: true
......@@ -7,7 +7,7 @@
state: present
when:
- ansible_distribution == "Fedora"
- ansible_distribution_major_version > 21
- ansible_distribution_major_version is version('21', '>')
- ansible_selinux_python_present == false
become: true
......
......@@ -14,7 +14,7 @@
- copr
when:
- ansible_distribution == "Fedora"
- ansible_distribution_major_version > 26
- ansible_distribution_major_version is version('26', '>')
become: true
- name: Import GPG key
......
......@@ -3,10 +3,8 @@
- name: Install nautilus packages
dnf:
name: "{{ item }}"
name: "{{ nautilus_packages | map(attribute='dnf') | list }}"
state: present
with_items:
- "{{ nautilus_packages | map(attribute='dnf') | list }}"
tags:
- nautilus
- dnf
......
......@@ -7,21 +7,20 @@
state: present
when:
- ansible_distribution == "Fedora"
- ansible_distribution_major_version > 21
- ansible_distribution_major_version is version('21', '>')
- ansible_selinux_python_present == false
become: true
- name: Install Nextcloud
dnf:
name: "{{ item }}"
name:
- nextcloud-client
- nextcloud-client-nautilus
state: present
when:
- ansible_distribution == "Fedora"
- ansible_distribution_major_version > 21
- ansible_distribution_major_version is version('21', '>')
become: true
with_items:
- nextcloud-client
- nextcloud-client-nautilus
- name: Preconfigure Nextcloud
template:
......
......@@ -13,7 +13,7 @@
- copr
when:
- ansible_distribution == "Fedora"
- ansible_distribution_major_version > 21
- ansible_distribution_major_version is version('21', '>')
become: true
- name: Install Riot
......